<!DOCTYPE html><html lang="en-CA"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><meta http-equiv="X-UA-Compatible" content="IE=edge"><meta name="HandheldFriendly" content="true"><link rel="profile" href="https://gmpg.org/xfn/11"><title>&quot;The Flash&quot; actor Logan Williams died at 16</title><style id="rocket-critical-css">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</style><link rel="preload" href="https://thecheapseats.ca/wp-content/cache/min/1/a88e93b04e4703f2b012e777ebb0e32e.css" as="style" onload="this.onload=null;this.rel='stylesheet'" data-minify="1" /><meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/><link rel="canonical" href="https://thecheapseats.ca/the-flash-actor-logan-williams-died-at-16/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="&quot;The Flash&quot; actor Logan Williams died at 16" /><meta property="og:description" content="Get all the latest coronavirus news and more daily in your inbox. register here. Logan williams, the young face of Barry Allen in the popular CW series “The flash&#8220;Died Thursday, according to reports. Although no cause of death has been given, Williams&#8217; mother Marlyse Williams is &#8220;absolutely devastated&#8221; by the death of the teenager and &hellip;" /><meta property="og:url" content="https://thecheapseats.ca/the-flash-actor-logan-williams-died-at-16/" /><meta property="og:site_name" content="The Cheap Seats" /><meta property="article:section" content="Latest Headlines" /><meta property="article:published_time" content="2020-04-03T23:30:08+00:00" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Get all the latest coronavirus news and more daily in your inbox. register here. Logan williams, the young face of Barry Allen in the popular CW series “The flash&#8220;Died Thursday, according to reports. Although no cause of death has been given, Williams&#8217; mother Marlyse Williams is &#8220;absolutely devastated&#8221; by the death of the teenager and [&hellip;]" /><meta name="twitter:title" content="&quot;The Flash&quot; actor Logan Williams died at 16" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://thecheapseats.ca/#website","url":"https://thecheapseats.ca/","name":"The Cheap Seats","inLanguage":"en-CA","description":"Complete Canadian News World in English","potentialAction":{"@type":"SearchAction","target":"https://thecheapseats.ca/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://thecheapseats.ca/the-flash-actor-logan-williams-died-at-16/#webpage","url":"https://thecheapseats.ca/the-flash-actor-logan-williams-died-at-16/","name":"&quot;The Flash&quot; actor Logan Williams died at 16","isPartOf":{"@id":"https://thecheapseats.ca/#website"},"inLanguage":"en-CA","datePublished":"2020-04-03T23:30:08+00:00","dateModified":"2020-04-03T23:30:08+00:00","author":{"@id":"https://thecheapseats.ca/#/schema/person/3922eaddce1690eeced358bbccfde3f2"}},{"@type":["Person"],"@id":"https://thecheapseats.ca/#/schema/person/3922eaddce1690eeced358bbccfde3f2","name":"Julien","image":{"@type":"ImageObject","@id":"https://thecheapseats.ca/#authorlogo","inLanguage":"en-CA","url":"https://secure.gravatar.com/avatar/5bbceaaefdfa516bf7c3544a7dbf934f?s=96&d=mm&r=g","caption":"Julien"},"sameAs":[]}]}</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel="alternate" type="application/rss+xml" title="The Cheap Seats &raquo; Feed" href="https://thecheapseats.ca/feed/" /><link rel="alternate" type="application/rss+xml" title="The Cheap Seats &raquo; Comments Feed" href="https://thecheapseats.ca/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="The Cheap Seats &raquo; &#8220;The Flash&#8221; actor Logan Williams died at 16 Comments Feed" href="https://thecheapseats.ca/the-flash-actor-logan-williams-died-at-16/feed/" /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><link rel='preload' id='demo_fonts-css' href='//fonts.googleapis.com/css?family=Open+Sans%3Aregular%2Citalic%2C700|Roboto+Condensed%3Aregular%2Citalic%2C700%26subset%3Dlatin%2C' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='screen' /> <script type='text/javascript' src='https://thecheapseats.ca/wp-content/cache/busting/1/wp-includes/js/jquery/jquery-1.12.4-wp.js'></script>   <link rel='https://api.w.org/' href='https://thecheapseats.ca/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://thecheapseats.ca/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://thecheapseats.ca/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.3.2" /><link rel='shortlink' href='https://thecheapseats.ca/?p=6813' /><link rel="alternate" type="application/json+oembed" href="https://thecheapseats.ca/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthecheapseats.ca%2Fthe-flash-actor-logan-williams-died-at-16%2F" /><link rel="alternate" type="text/xml+oembed" href="https://thecheapseats.ca/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthecheapseats.ca%2Fthe-flash-actor-logan-williams-died-at-16%2F&#038;format=xml" /> <script data-ad-client="ca-pub-8512117689471250" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script data-ad-client="ca-pub-6339419063394600" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script data-ad-client="ca-pub-9373527821382765" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script data-ad-client="ca-pub-1002222987041100" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><link rel="pingback" href="https://thecheapseats.ca/xmlrpc.php"><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript><script>/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))</script> <style type="text/css" media="all">body,h1,h2,h3,h4,h5,h6,.breadcrumbs h3,.section-header h3,label,input,input[type="text"],input[type="email"],input[type="url"],input[type="search"],input[type="password"],textarea,button,.btn,input[type="submit"],input[type="reset"],input[type="button"],table,#primary-menu li li a,.sidebar .widget_ad .widget-title,.site-footer .widget_ad .widget-title{font-family:"Open Sans","Helvetica Neue",Helvetica,Arial,sans-serif}#primary-menu li a,h3.section-heading,.widget-title,.breadcrumbs h3,button,.btn,input[type="submit"],input[type="reset"],input[type="button"]{font-family:"Roboto Condensed","Helvetica Neue",Helvetica,Arial,sans-serif}a,a:visited,a:hover,.site-title a:hover,#primary-bar.bar-1 #primary-menu li a:hover,.mobile-menu ul li a:hover,.entry-meta a,.edit-link a,.comment-reply-title small a:hover,.entry-content a,.entry-content a:visited,.page-content a,.page-content a:visited,.pagination .page-numbers.current,.content-block .section-heading h3 a,.content-block .section-heading h3 a:visited,.pagination .page-numbers:hover,.sidebar .widget a:hover,.site-footer .widget a:hover,.sidebar .widget ul li a:hover,.site-footer .widget ul li a:hover,.entry-related .hentry .entry-title a:hover,.author-box .author-name span a:hover,.entry-tags .tag-links a:hover:before,.widget_tag_cloud .tagcloud a:hover:before,.entry-content a:hover,.page-content a:hover,.content-block .section-heading h3 a:hover,.content-block .section-heading .section-more-link a:hover,.entry-meta .entry-comment a:hover,.entry-title a:hover,.page-content ul li:before,.entry-content ul li:before,.site-footer.footer-light .footer-nav li a:hover,.site-footer.footer-dark .footer-nav li a:hover,.site-footer.footer-light #site-bottom .site-info a:hover,.site-footer.footer-dark #site-bottom .site-info a:hover,h3.section-heading,h3.section-heading a,.three-column-block .column-one .hentry a:hover .entry-title,#site-bottom .site-info a:hover,.header-date,.search-button .genericon:hover,.search-button .genericon.active,.slogan h4{color:#de0f17}.mobile-menu-icon .menu-icon-close,.mobile-menu-icon .menu-icon-open,.more-button a,.more-button a:hover,.entry-header .entry-category-icon a,.three-column-block .column-one h3.section-heading,.header-date .arrow-right:before,.header-search .search-submit,button,.btn,input[type="submit"],input[type="reset"],input[type="button"],button:hover,.btn:hover,input[type="reset"]:hover,input[type="submit"]:hover,input[type="button"]:hover{background-color:#de0f17}.my-pager a:hover,.my-pager a.active,.header-search .search-submit{border-color:#de0f17}#primary-bar.bar-2{background-color:#fff}</style></head><body data-rsssl=1 class="post-template-default single single-post postid-6813 single-format-standard group-blog"><div id="page" class="site"><header id="masthead" class="site-header clear"><div id="top-bar" class="container clear"> <span class="header-date"> <span class="arrow-right"></span> Friday, April 3, 2020 </span> <span class="search-button"> <span class="genericon genericon-search"> <strong>Search</strong></span> <span class="genericon genericon-close"> <strong>Search</strong></span> </span><div class="header-search"><form id="searchform" method="get" action="https://thecheapseats.ca/"> <input type="search" name="s" class="search-input" placeholder="Enter keywords..." autocomplete="off"> <button type="submit" class="search-submit">Go</button></form></div> <span class="header-social "> </span> <span class="mobile-menu-icon"> <span class="menu-icon-open">Menu</span> <span class="menu-icon-close"><span class="genericon genericon-close"></span></span> </span></div><div class="site-start clear header-1"><div class="container"><div class="site-branding"><div id="logo"> <span class="helper"></span> <a href="https://thecheapseats.ca/" rel="home"> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" data-lazy-src="https://thecheapseats.ca/wp-content/uploads/2020/02/Screenshot_2.png"/><noscript><img src="https://thecheapseats.ca/wp-content/uploads/2020/02/Screenshot_2.png" alt=""/></noscript> </a></div></div><div class="slogan slogan-left"><div class="slogan-content"><h4></h4><p></p></div></div><div class="slogan slogan-right"><div class="slogan-content"><h4></h4><p></p></div></div></div></div><div id="primary-bar" class="container clear bar-1"><nav id="primary-nav" class="primary-navigation"><div class="menu-secondary-menu-container"><ul id="primary-menu" class="sf-menu"><li id="menu-item-447" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447"><a href="https://thecheapseats.ca/canada/">Canada</a></li><li id="menu-item-444" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-444"><a href="https://thecheapseats.ca/latest-headlines/">Latest Headlines</a></li><li id="menu-item-446" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-446"><a href="https://thecheapseats.ca/olympics/">Olympics</a></li><li id="menu-item-445" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-445"><a href="https://thecheapseats.ca/politics/">Politics</a></li><li id="menu-item-442" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-442"><a href="https://thecheapseats.ca/entertainment/">Entertainment</a></li><li id="menu-item-443" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-443"><a href="https://thecheapseats.ca/health/">Health</a></li></ul></div></nav></div><div id="secondary-bar" class="container clear"><nav id="secondary-nav" class="secondary-navigation"><div class="menu-primary-menu-container"><ul id="secondary-menu" class="sf-menu"><li id="menu-item-438" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-438"><a href="https://thecheapseats.ca/dmca/">DMCA</a></li><li id="menu-item-439" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-439"><a href="https://thecheapseats.ca/about-us/">About Us</a></li><li id="menu-item-440" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-440"><a href="https://thecheapseats.ca/contact-us/">Contact Us</a></li><li id="menu-item-441" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-441"><a href="https://thecheapseats.ca/privacy-policy/">Privacy Policy</a></li></ul></div></nav></div><div class="mobile-menu clear"><div class="container"><div class="menu-left"><h3>Categories</h3><div class="menu-secondary-menu-container"><ul id="primary-mobile-menu" class=""><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447"><a href="https://thecheapseats.ca/canada/">Canada</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-444"><a href="https://thecheapseats.ca/latest-headlines/">Latest Headlines</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-446"><a href="https://thecheapseats.ca/olympics/">Olympics</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-445"><a href="https://thecheapseats.ca/politics/">Politics</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-442"><a href="https://thecheapseats.ca/entertainment/">Entertainment</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-443"><a href="https://thecheapseats.ca/health/">Health</a></li></ul></div></div><div class="menu-right"><h3>Pages</h3><div class="menu-primary-menu-container"><ul id="secondary-mobile-menu" class=""><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-438"><a href="https://thecheapseats.ca/dmca/">DMCA</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-439"><a href="https://thecheapseats.ca/about-us/">About Us</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-440"><a href="https://thecheapseats.ca/contact-us/">Contact Us</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-441"><a href="https://thecheapseats.ca/privacy-policy/">Privacy Policy</a></li></ul></div></div></div></div></header><div id="content" class="site-content container clear"><div id="primary" class="content-area"><main id="main" class="site-main" ><article id="post-6813" class="post-6813 post type-post status-publish format-standard hentry category-latest-headlines"><header class="entry-header clear"><div class="entry-category-icon"><a href="https://thecheapseats.ca/latest-headlines/" title="View all posts in Latest Headlines" >Latest Headlines</a></div><h1 class="entry-title">&#8220;The Flash&#8221; actor Logan Williams died at 16</h1><div class="entry-meta clear"> <span class="entry-author"><a href="https://thecheapseats.ca/author/vihaan/"><img class="avatar avatar-48 photo" width="64" height="64" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-lazy-src="https://thecheapseats.ca/wp-content/uploads/2020/02/VIF8912_2626804637_l-150x150.jpg"/><noscript><img class="avatar avatar-48 photo" width="64" height="64" src="https://thecheapseats.ca/wp-content/uploads/2020/02/VIF8912_2626804637_l-150x150.jpg"/></noscript></a> <a href="https://thecheapseats.ca/author/vihaan/" title="Posts by Julien" rel="author">Julien</a> &#8212; </span> <span class="entry-date">April 3, 2020</span> <span class='entry-comment'><a href="https://thecheapseats.ca/the-flash-actor-logan-williams-died-at-16/#respond" class="comments-link" >0 comment</a></span></div><div class="social-share-icons"> <a href="https://twitter.com/intent/tweet?text=%26%238220%3BThe+Flash%26%238221%3B+actor+Logan+Williams+died+at+16&amp;url=https%3A%2F%2Fthecheapseats.ca%2Fthe-flash-actor-logan-williams-died-at-16%2F" target="_blank"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" data-lazy-src="https://thecheapseats.ca/wp-content/themes/advanced-magazine-pro/assets/img/icon-twitter-square.png"/><noscript><img src="https://thecheapseats.ca/wp-content/themes/advanced-magazine-pro/assets/img/icon-twitter-square.png" alt=""/></noscript></a> <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fthecheapseats.ca%2Fthe-flash-actor-logan-williams-died-at-16%2F" target="_blank"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" data-lazy-src="https://thecheapseats.ca/wp-content/themes/advanced-magazine-pro/assets/img/icon-facebook-square.png"/><noscript><img src="https://thecheapseats.ca/wp-content/themes/advanced-magazine-pro/assets/img/icon-facebook-square.png" alt=""/></noscript></a> <a href="https://plus.google.com/share?url=https%3A%2F%2Fthecheapseats.ca%2Fthe-flash-actor-logan-williams-died-at-16%2F" target="_blank"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" data-lazy-src="https://thecheapseats.ca/wp-content/themes/advanced-magazine-pro/assets/img/icon-google-plus-square.png"/><noscript><img src="https://thecheapseats.ca/wp-content/themes/advanced-magazine-pro/assets/img/icon-google-plus-square.png" alt=""/></noscript></a> <a href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fthecheapseats.ca%2Fthe-flash-actor-logan-williams-died-at-16%2F&amp;media=" target="_blank"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" data-lazy-src="https://thecheapseats.ca/wp-content/themes/advanced-magazine-pro/assets/img/icon-pinterest-square.png"/><noscript><img src="https://thecheapseats.ca/wp-content/themes/advanced-magazine-pro/assets/img/icon-pinterest-square.png" alt=""/></noscript></a> <a href="/cdn-cgi/l/email-protection#0b34787e69616e687f362e393d2e39383339393b2e38495f636e2e393b4d676a78632e393d2e39383339393a2e38492e393b6a687f64792e393b47646c6a652e393b5c626767626a66782e393b6f626e6f2e393b6a7f2e393b3a3d2d69646f7236637f7f7b783124247f636e68636e6a7b786e6a7f7825686a247f636e266d676a7863266a687f64792667646c6a65267c626767626a6678266f626e6f266a7f263a3d24" target="_blank"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" data-lazy-src="https://thecheapseats.ca/wp-content/themes/advanced-magazine-pro/assets/img/icon-mail-square.png"/><noscript><img src="https://thecheapseats.ca/wp-content/themes/advanced-magazine-pro/assets/img/icon-mail-square.png" alt=""/></noscript></a></div></header><div class="entry-content"><div><p class="speakable"><strong>Get all the latest coronavirus news and more daily in your inbox. <a href="https://www.foxnews.com/newsletters/coronavirus" rel="noopener noreferrer" target="_blank">register here</a>.</strong></p><p class="speakable"><a href="https://www.foxnews.com/category/entertainment/celebrity-news" target="_blank" rel="noopener noreferrer">Logan williams</a>, the young face of Barry Allen in the popular CW series “<a href="https://www.foxnews.com/category/entertainment/tv" target="_blank" rel="noopener noreferrer">The flash</a>&#8220;Died Thursday, according to reports.</p><p>Although no cause of death has been given, Williams&#8217; mother Marlyse Williams is &#8220;absolutely devastated&#8221; by the death of the teenager and the fact that the family should not cry together because of the <a href="https://www.foxnews.com/category/health/infectious-disease/coronavirus">coronavirus</a> pandemic that caused mandatory physical distance, according to Coquitlam, based in British Columbia <a href="http://www.tricitynews.com/news/coquitlam-teen-actor-logan-williams-young-flash-in-the-tv-series-dies-suddenly-1.24112183" target="_blank" rel="noopener noreferrer">Tri-City News</a>.</p><p>&#8220;I can&#8217;t hug my parents who lost their only grandchild,&#8221; Marlyse Williams told the publication.</p><p><strong><a href="https://www.foxnews.com/entertainment/lean-on-me-songwriter-bill-withers-dead-at-81" target="_blank" rel="noopener noreferrer">LEAN ON ME</a></strong></p><p>&#8220;With his talent and magnificent looks, Logan had the potential to be a huge star,&#8221; added Williams&#8217; mother.</p><p>Friday, the star of the show, Grant Gustin, went on Instagram to remember his boyfriend and share a photo of Williams with actor Jesse L. Martin which was taken in 2014 during the filming of the pilot of the show.</p><p><strong><a href="https://www.foxnews.com/entertainment/fountains-of-wayne-singer-adam-schlesinger-dead-coronavirus" target="_blank" rel="noopener noreferrer">THE FOUNTAINS OF WAYNE SINGER ADAM SCHLESINGER DEATH FROM CORONAVIRUS COMPLICATIONS</a></strong></p><p>&#8220;Just upon hearing the devastating news that Logan Williams died suddenly,&#8221; he wrote. “I was so impressed not only with Logan&#8217;s talent but also with his professionalism on set. My thoughts and prayers will be with him and his family during what is, I am sure, an unimaginably difficult time for them. &#8220;</p><p>He added, &#8220;Please keep Logan and his family in your thoughts and prayers during this strange and trying time for all of us. Send love to everyone. &#8220;</p><p>Meanwhile, John Wesley Shipp &#8211; who played Barry Allen in the early 1990s in the adaptation of &#8220;The Flash&#8221; as well as the character&#8217;s father, Henry, in the remake &#8211; also extended his condolences to the teenager and his family.</p><p><strong><a href="https://www.foxnews.com/entertainment/little-women-christy-mcginity-very-thankful-support-death-2-week-old-daughter" target="_blank" rel="noopener noreferrer">&#8216;LITTLE WOMEN: THE&#8217; STAR CHRISTY MCGINITY &#8216;VERY THANKS&#8217; FOR 2 WEEK AFTER DEATH SUPPORT</a></strong></p><p>&#8220;Heartsick learns of the death of Logan Williams at 16,&#8221; he said. <a href="https://twitter.com/JohnWesleyShipp/status/1246182031870119936" target="_blank" rel="noopener noreferrer">tweeted</a> Friday. &#8220;He was 100% determined to play young Barry Allen, and he missed us once we got past this part of the story. Love and compassion for Logan&#8217;s family and friends in your grief. &#8220;</p><p>Williams also starred in the Hallmark Channel series &#8220;When Calls the Heart&#8221; alongside <a href="https://www.foxnews.com/category/person/lori-loughlin" target="_blank" rel="noopener noreferrer">Lori Loughlin</a> and on the &#8220;Supernatural&#8221; of the CW. Erin Krakow, who plays in the Hallmark series, <a href="https://twitter.com/erinkrakow/status/1246184278473363457" target="_blank" rel="noopener noreferrer">said she was heartbroken</a> by the news in a post on Twitter.</p><p><strong><a href="https://www.foxnews.com/apps-products?pid=AppArticleLink" target="_blank" rel="noopener noreferrer">CLICK HERE TO GET THE FOX NEWS APP</a></strong></p><p>&#8220;Logan was a handsome, warm, silly and talented young man&#8221;, Krakow <a href="https://twitter.com/erinkrakow/status/1246184366914465793" target="_blank" rel="noopener noreferrer">added in a separate tweet</a>. &#8220;He could always make us laugh. He was barely 17 and had what I am sure would have been a very bright future. &#8220;</p><p>Tri-City News said that Williams also leaves to mourn his father, Clive, as well as his grandparents, aunts and uncles.</p><p></div><p></p></div> <span class="entry-tags"> </span></article><div class="entry-related clear"><h3>Recommended For You</h3><div class="related-loop clear"><div class="hentry"> <a class="thumbnail-link" href="https://thecheapseats.ca/nasty-nellie-alison-arngrim-reads-little-house-on-the-prairie-books-for-fans-during-the-coronavirus-pandemic/"><div class="thumbnail-wrap"> <img width="300" height="200" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20200'%3E%3C/svg%3E" class="attachment-post_thumb size-post_thumb wp-post-image" alt="“Nasty Nellie” Alison Arngrim reads “Little House on the Prairie” books for fans during the coronavirus pandemic" data-lazy-srcset="https://thecheapseats.ca/wp-content/uploads/2020/04/1585950526_“Nasty-Nellie”-Alison-Arngrim-reads-“Little-House-on-the-Prairie”-300x200.jpg 300w, https://thecheapseats.ca/wp-content/uploads/2020/04/1585950526_“Nasty-Nellie”-Alison-Arngrim-reads-“Little-House-on-the-Prairie”-720x480.jpg 720w, https://thecheapseats.ca/wp-content/uploads/2020/04/1585950526_“Nasty-Nellie”-Alison-Arngrim-reads-“Little-House-on-the-Prairie”-600x400.jpg 600w, https://thecheapseats.ca/wp-content/uploads/2020/04/1585950526_“Nasty-Nellie”-Alison-Arngrim-reads-“Little-House-on-the-Prairie”-150x100.jpg 150w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://thecheapseats.ca/wp-content/uploads/2020/04/1585950526_“Nasty-Nellie”-Alison-Arngrim-reads-“Little-House-on-the-Prairie”-300x200.jpg" /><noscript><img width="300" height="200" src="https://thecheapseats.ca/wp-content/uploads/2020/04/1585950526_“Nasty-Nellie”-Alison-Arngrim-reads-“Little-House-on-the-Prairie”-300x200.jpg" class="attachment-post_thumb size-post_thumb wp-post-image" alt="“Nasty Nellie” Alison Arngrim reads “Little House on the Prairie” books for fans during the coronavirus pandemic" srcset="https://thecheapseats.ca/wp-content/uploads/2020/04/1585950526_“Nasty-Nellie”-Alison-Arngrim-reads-“Little-House-on-the-Prairie”-300x200.jpg 300w, https://thecheapseats.ca/wp-content/uploads/2020/04/1585950526_“Nasty-Nellie”-Alison-Arngrim-reads-“Little-House-on-the-Prairie”-720x480.jpg 720w, https://thecheapseats.ca/wp-content/uploads/2020/04/1585950526_“Nasty-Nellie”-Alison-Arngrim-reads-“Little-House-on-the-Prairie”-600x400.jpg 600w, https://thecheapseats.ca/wp-content/uploads/2020/04/1585950526_“Nasty-Nellie”-Alison-Arngrim-reads-“Little-House-on-the-Prairie”-150x100.jpg 150w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></div> </a><h2 class="entry-title"><a href="https://thecheapseats.ca/nasty-nellie-alison-arngrim-reads-little-house-on-the-prairie-books-for-fans-during-the-coronavirus-pandemic/">“Nasty Nellie” Alison Arngrim reads “Little House on the Prairie” books for fans during the coronavirus pandemic</a></h2></div><div class="hentry"> <a class="thumbnail-link" href="https://thecheapseats.ca/supporting-the-front-line-americans-raise-thousands-to-feed-healthcare-workers/"><div class="thumbnail-wrap"> <img width="300" height="200" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20200'%3E%3C/svg%3E" class="attachment-post_thumb size-post_thumb wp-post-image" alt="Supporting the front line: Americans raise thousands to feed healthcare workers" data-lazy-srcset="https://thecheapseats.ca/wp-content/uploads/2020/04/Supporting-the-front-line-Americans-raise-thousands-to-feed-healthcare-300x200.jpg 300w, https://thecheapseats.ca/wp-content/uploads/2020/04/Supporting-the-front-line-Americans-raise-thousands-to-feed-healthcare-720x480.jpg 720w, https://thecheapseats.ca/wp-content/uploads/2020/04/Supporting-the-front-line-Americans-raise-thousands-to-feed-healthcare-600x400.jpg 600w, https://thecheapseats.ca/wp-content/uploads/2020/04/Supporting-the-front-line-Americans-raise-thousands-to-feed-healthcare-150x100.jpg 150w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://thecheapseats.ca/wp-content/uploads/2020/04/Supporting-the-front-line-Americans-raise-thousands-to-feed-healthcare-300x200.jpg" /><noscript><img width="300" height="200" src="https://thecheapseats.ca/wp-content/uploads/2020/04/Supporting-the-front-line-Americans-raise-thousands-to-feed-healthcare-300x200.jpg" class="attachment-post_thumb size-post_thumb wp-post-image" alt="Supporting the front line: Americans raise thousands to feed healthcare workers" srcset="https://thecheapseats.ca/wp-content/uploads/2020/04/Supporting-the-front-line-Americans-raise-thousands-to-feed-healthcare-300x200.jpg 300w, https://thecheapseats.ca/wp-content/uploads/2020/04/Supporting-the-front-line-Americans-raise-thousands-to-feed-healthcare-720x480.jpg 720w, https://thecheapseats.ca/wp-content/uploads/2020/04/Supporting-the-front-line-Americans-raise-thousands-to-feed-healthcare-600x400.jpg 600w, https://thecheapseats.ca/wp-content/uploads/2020/04/Supporting-the-front-line-Americans-raise-thousands-to-feed-healthcare-150x100.jpg 150w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></div> </a><h2 class="entry-title"><a href="https://thecheapseats.ca/supporting-the-front-line-americans-raise-thousands-to-feed-healthcare-workers/">Supporting the front line: Americans raise thousands to feed healthcare workers</a></h2></div><div class="hentry last"> <a class="thumbnail-link" href="https://thecheapseats.ca/madonna-joins-bill-and-melinda-gates-foundation-in-coronavirus-relief-efforts/"><div class="thumbnail-wrap"> <img width="300" height="200" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20200'%3E%3C/svg%3E" class="attachment-post_thumb size-post_thumb wp-post-image" alt="Madonna Joins Bill and Melinda Gates Foundation in Coronavirus Relief Efforts" data-lazy-srcset="https://thecheapseats.ca/wp-content/uploads/2020/04/1585938182_Madonna-Joins-Bill-and-Melinda-Gates-Foundation-in-Coronavirus-Relief-300x200.jpg 300w, https://thecheapseats.ca/wp-content/uploads/2020/04/1585938182_Madonna-Joins-Bill-and-Melinda-Gates-Foundation-in-Coronavirus-Relief-720x480.jpg 720w, https://thecheapseats.ca/wp-content/uploads/2020/04/1585938182_Madonna-Joins-Bill-and-Melinda-Gates-Foundation-in-Coronavirus-Relief-600x400.jpg 600w, https://thecheapseats.ca/wp-content/uploads/2020/04/1585938182_Madonna-Joins-Bill-and-Melinda-Gates-Foundation-in-Coronavirus-Relief-150x100.jpg 150w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://thecheapseats.ca/wp-content/uploads/2020/04/1585938182_Madonna-Joins-Bill-and-Melinda-Gates-Foundation-in-Coronavirus-Relief-300x200.jpg" /><noscript><img width="300" height="200" src="https://thecheapseats.ca/wp-content/uploads/2020/04/1585938182_Madonna-Joins-Bill-and-Melinda-Gates-Foundation-in-Coronavirus-Relief-300x200.jpg" class="attachment-post_thumb size-post_thumb wp-post-image" alt="Madonna Joins Bill and Melinda Gates Foundation in Coronavirus Relief Efforts" srcset="https://thecheapseats.ca/wp-content/uploads/2020/04/1585938182_Madonna-Joins-Bill-and-Melinda-Gates-Foundation-in-Coronavirus-Relief-300x200.jpg 300w, https://thecheapseats.ca/wp-content/uploads/2020/04/1585938182_Madonna-Joins-Bill-and-Melinda-Gates-Foundation-in-Coronavirus-Relief-720x480.jpg 720w, https://thecheapseats.ca/wp-content/uploads/2020/04/1585938182_Madonna-Joins-Bill-and-Melinda-Gates-Foundation-in-Coronavirus-Relief-600x400.jpg 600w, https://thecheapseats.ca/wp-content/uploads/2020/04/1585938182_Madonna-Joins-Bill-and-Melinda-Gates-Foundation-in-Coronavirus-Relief-150x100.jpg 150w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></div> </a><h2 class="entry-title"><a href="https://thecheapseats.ca/madonna-joins-bill-and-melinda-gates-foundation-in-coronavirus-relief-efforts/">Madonna Joins Bill and Melinda Gates Foundation in Coronavirus Relief Efforts</a></h2></div></div></div><div class="author-box clear"> <a href="https://thecheapseats.ca/author/vihaan/"><img class="avatar avatar-120 photo" width="64" height="64" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-lazy-src="https://thecheapseats.ca/wp-content/uploads/2020/02/VIF8912_2626804637_l-150x150.jpg"/><noscript><img class="avatar avatar-120 photo" width="64" height="64" src="https://thecheapseats.ca/wp-content/uploads/2020/02/VIF8912_2626804637_l-150x150.jpg"/></noscript></a><div class="author-meta"><h4 class="author-name">About the Author: <span><a href="https://thecheapseats.ca/author/vihaan/">Julien</a></span></h4><div class="author-desc"></div></div></div><div id="comments" class="comments-area"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/the-flash-actor-logan-williams-died-at-16/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://thecheapseats.ca/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='6813' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p></form></div></div></main></div><aside id="secondary" class="widget-area sidebar"><div id="nav_menu-2" class="widget widget_nav_menu"><h2 class="widget-title"><span>Pages</span></h2><div class="menu-primary-menu-container"><ul id="menu-primary-menu" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-438"><a href="https://thecheapseats.ca/dmca/">DMCA</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-439"><a href="https://thecheapseats.ca/about-us/">About Us</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-440"><a href="https://thecheapseats.ca/contact-us/">Contact Us</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-441"><a href="https://thecheapseats.ca/privacy-policy/">Privacy Policy</a></li></ul></div></div><div id="nav_menu-3" class="widget widget_nav_menu"><h2 class="widget-title"><span>Home</span></h2><div class="menu-secondary-menu-container"><ul id="menu-secondary-menu" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447"><a href="https://thecheapseats.ca/canada/">Canada</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-444"><a href="https://thecheapseats.ca/latest-headlines/">Latest Headlines</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-446"><a href="https://thecheapseats.ca/olympics/">Olympics</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-445"><a href="https://thecheapseats.ca/politics/">Politics</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-442"><a href="https://thecheapseats.ca/entertainment/">Entertainment</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-443"><a href="https://thecheapseats.ca/health/">Health</a></li></ul></div></div><div id="categories-2" class="widget widget_categories"><h2 class="widget-title"><span>Categories</span></h2><ul><li class="cat-item cat-item-1"><a href="https://thecheapseats.ca/canada/">Canada</a> (837)</li><li class="cat-item cat-item-12"><a href="https://thecheapseats.ca/health/">Health</a> (550)</li><li class="cat-item cat-item-15"><a href="https://thecheapseats.ca/latest-headlines/">Latest Headlines</a> (689)</li><li class="cat-item cat-item-14"><a href="https://thecheapseats.ca/olympics/">Olympics</a> (192)</li><li class="cat-item cat-item-13"><a href="https://thecheapseats.ca/politics/">Politics</a> (1,087)</li></ul></div><div id="pages-2" class="widget widget_pages"><h2 class="widget-title"><span>Important Pages</span></h2><ul><li class="page_item page-item-433"><a href="https://thecheapseats.ca/about-us/">About Us</a></li><li class="page_item page-item-431"><a href="https://thecheapseats.ca/contact-us/">Contact Us</a></li><li class="page_item page-item-435"><a href="https://thecheapseats.ca/dmca/">DMCA</a></li><li class="page_item page-item-429"><a href="https://thecheapseats.ca/privacy-policy/">Privacy Policy</a></li></ul></div></aside></div><footer id="colophon" class="site-footer footer-light"><div class="menu-secondary-menu-container"><ul id="footer-menu" class="footer-nav container"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-447"><a href="https://thecheapseats.ca/canada/">Canada</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-444"><a href="https://thecheapseats.ca/latest-headlines/">Latest Headlines</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-446"><a href="https://thecheapseats.ca/olympics/">Olympics</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-445"><a href="https://thecheapseats.ca/politics/">Politics</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-442"><a href="https://thecheapseats.ca/entertainment/">Entertainment</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-443"><a href="https://thecheapseats.ca/health/">Health</a></li></ul></div><div class="clear"></div><div id="site-bottom" class="container clear"><div class="site-info"> &copy; 2020 <a href="https://thecheapseats.ca">The Cheap Seats</a> - Theme by <a href="https://www.happythemes.com/" target="_blank">HappyThemes</a></div></div></footer></div><div id="back-top"> <a href="#top" title="Back to top"><span class="genericon genericon-collapse"></span></a></div>         <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://thecheapseats.ca/wp-content/plugins/wp-rocket/assets/js/lazyload/12.0/lazyload.min.js"></script> <script src="https://thecheapseats.ca/wp-content/cache/min/1/088795907d006f55b44cc7d8b0717fbb.js" data-minify="1" defer></script><noscript><link rel="stylesheet" href="https://thecheapseats.ca/wp-content/cache/min/1/a88e93b04e4703f2b012e777ebb0e32e.css" data-minify="1" /></noscript><noscript><link rel='stylesheet' id='demo_fonts-css' href='//fonts.googleapis.com/css?family=Open+Sans%3Aregular%2Citalic%2C700|Roboto+Condensed%3Aregular%2Citalic%2C700%26subset%3Dlatin%2C' type='text/css' media='screen' /></noscript></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1585956612 -->